ownCloudHoy migramos un servidor ownCloud v6.0.4.1 a la nueva versión de ownCloud 7.0.2.

El servidor en que corre esta instalación:

Server: Apache v2.2.22
Database: MySQL v5.5.40
OC-Version: v7.0.2
PHP-Version: v5.4.34

Las migraciones de ownCloud no son complejas, es mas todo el trasfondo de pasos y cuidados que tomamos para no perder datos de ningún tipo, ( ni archivos de los usuarios, ni problemas con la base de datos, etc.).

Tomamos todas las precauciones necesarias para evitar cualquier tipo de imprevisto, el servidor estaba pleno funcionamiento y no era posible detenerlo o desconectarlo.

Este servidor ownCloud tiene la particularidad que validar los usuarios contra un servidor Samba que corre en el mismo equipo.

Para que ownCloud valide a los usuarios contra un Servidor Externo, como se detalla en el manual de ownCloud v.7, debemos declarar las siguientes líneas en el archivo de configuración, (/owncloud/config/config.php)

"user_backends" => array (
    0 => array (
            "class"     => "OC_User_SMB",
            "arguments" => array (
                              0 => 'localhost'
                              ),
    ),
),

Pero como es una instalación que lleva varios años funcionando y con varias actualizaciones, se tenía declarado un «require_one» en el mismo archivo de configuración:

require_once(dirname(__FILE__).'/../apps/user_external/lib/smb.php');

En el sistema de «pruebas» realizamos lo siguiente

  1. Migración de los datos de los usuarios
  2. Migración de la Base de Datos
  3. Pruebas de conexión con la base de datos
  4. Actualización de la aplicación de la v6 a la v7
  5. Pruebas de conexión con la base de datos
  6. Acceso de usuarios locales del ownCloud
  7. Modificación de archivo de configuración para la validación de usuarios contra el servidor Samba

Y aquí el error, si solo se agregan las líneas que aconseja el manual para la validación externa de usuarios por SMB, la validación no se produce, y si agregamos la línea del «require_one» la respuesta es una Página en Blanco.

Realizamos varias pruebas, revisamos la configuración y concluimos que el error era del archivo «smb.php», para solucionas el escollo reemplazamos la versión incluida en la versión 7.0.2 de ownCloud por el archivo del ownCloud v6.0.4.1 a la nueva instalación, solucionado!.

Ahora los usuarios pueden acceder a todos sus documentos sin problemas, validándose con sus credenciales  Samba en el ownCloud actualizado.

 

WhatsApp chat